Error

object

Description of an error to help remediation.

messagestringrequired

A human-readable explanation specific to this error.

Example:Unauthorized

errorDetailobject

Additional information about the error.

Show Child Parameters
Example

ParameterLocation

string

The location of the invalid parameter.

Allowed values:BODYPATHQUERYHEADER

InvalidParams

object

List of invalid parameters.

Please note that the API GW does syntax validation according to the OAS and will issue an error response in case of failure. Thus, this extension should only be used when the API server is not connected to via the API GW or if additional (to what is defined in the OAS) checks are performed.

instringrequired

The location of the invalid parameter.

Allowed values:BODYPATHQUERYHEADER

namestringrequired

The name of the invalid parameter.

reasonstring

The reason why the parameter’s value is invalid.

codestring

An application specific error code that identifies univocally the error situation.

Match pattern:^[0-9A-Z_]{1,125}$

Example:THIS_IS_ERROR_CODE

valuestringrequired

The invalid value (as a string).

Example

MissingParams

object

List of missing parameters.

Please note that the API GW does syntax validation according to the OAS and will issue an error response in case of failure. Thus, this extension should only be used when the API server is not connected to via the API GW or if conditional presence conditions (that typically cannot be modeled in an OAS) are applicable.

instring

The location of the invalid parameter.

Allowed values:BODYPATHQUERYHEADER

namestring
reasonstring
codestring

An application specific error code that identifies univocally the error situation.

Match pattern:^[0-9A-Z_]{1,125}$

Example:THIS_IS_ERROR_CODE

Example

ErrorDetail

object

Detailed description of an error to help remediation. It follows RFC 7807 (https://datatracker.ietf.org/doc/html/rfc7807).

typestring(uri)

A URI reference (RFC3986) that describes the problem type (in the context of the provided API).

Should resolve to a human-readable document.

Default:about:blank

titlestring

A short, human-readable summary of the problem type in English.

Example:Not Found

statusinteger(int32)required

The HTTP status code (RFC7231, Section 6) generated by the origin server for this occurrence of the problem.

>= 100<= 599

Example:400

codestring

An application specific error code that identifies univocally the error situation.

Match pattern:^[0-9A-Z_]{1,125}$

Example:THIS_IS_ERROR_CODE

detailstring

A human-readable explanation specific to this occurrence of the problem.

Example:ISIN 'US012071998' does not exist.

instancestring(uri)

A URI reference (RFC3986) that identifies the specific occurrence of the problem. It may or may not yield further information if dereferenced.

Example:https://www.example.com/books/1234

missingParamsarray[object]

List of missing parameters.

Please note that the API GW does syntax validation according to the OAS and will issue an error response in case of failure. Thus, this extension should only be used when the API server is not connected to via the API GW or if conditional presence conditions (that typically cannot be modeled in an OAS) are applicable.

Example:{"in":"PATH","name":"paramName","reason":"The parameter 'paramName' is not present in PATH","code":"ERROR_INTERNAL"}

Show Child Parameters
invalidParamsarray[object]

List of invalid parameters.

Please note that the API GW does syntax validation according to the OAS and will issue an error response in case of failure. Thus, this extension should only be used when the API server is not connected to via the API GW or if additional (to what is defined in the OAS) checks are performed.

Example:{"in":"PATH","name":"paramName","reason":"Internal functional validation has ended in failure","value":"23.3","code":"ERROR_INTERNAL"}

Show Child Parameters
Example