ErrorDetail
objectDetailed description of an error to help remediation. It follows RFC 7807 (https://datatracker.ietf.org/doc/html/rfc7807).
A URI reference (RFC3986) that describes the problem type (in the context of the provided API).
Should resolve to a human-readable document.
Default:about:blank
A short, human-readable summary of the problem type in English.
Example:Not Found
The HTTP status code (RFC7231, Section 6) generated by the origin server for this occurrence of the problem.
>= 100<= 599
Example:400
An application specific error code that identifies univocally the error situation.
Match pattern:^[0-9A-Z_]{1,125}$
Example:THIS_IS_ERROR_CODE
A human-readable explanation specific to this occurrence of the problem.
Example:ISIN 'US012071998' does not exist.
A URI reference (RFC3986) that identifies the specific occurrence of the problem. It may or may not yield further information if dereferenced.
Example:https://www.example.com/books/1234
List of missing parameters.
Please note that the API GW does syntax validation according to the OAS and will issue an error response in case of failure. Thus, this extension should only be used when the API server is not connected to via the API GW or if conditional presence conditions (that typically cannot be modeled in an OAS) are applicable.
Example:{"in":"PATH","name":"paramName","reason":"The parameter 'paramName' is not present in PATH","code":"ERROR_INTERNAL"}
Show Child Parameters
List of invalid parameters.
Please note that the API GW does syntax validation according to the OAS and will issue an error response in case of failure. Thus, this extension should only be used when the API server is not connected to via the API GW or if additional (to what is defined in the OAS) checks are performed.
Example:{"in":"PATH","name":"paramName","reason":"Internal functional validation has ended in failure","value":"23.3","code":"ERROR_INTERNAL"}
Show Child Parameters
ServerErrorCode
stringAn application specific error code that identifies univocally the error situation.
Match pattern:^[0-9A-Z_]{1,125}$
CalculationAttributesType
objectBasic attributes of the object.
Creation date of the calculation
Example:2022-01-02T18:25:43.511Z
Status of the calculation process
Allowed values:IN-PROGRESSDONE
Example:IN-PROGRESS
SimulationType
objectData structure for all operations.
Basic attributes of the object.
Show Child Parameters
UUID type implementing the RFC 4122.
Match pattern:^[0-9a-fA-F]{8}\b-[0-9a-fA-F]{4}\b-[0-9a-fA-F]{4}\b-[0-9a-fA-F]{4}\b-[0-9a-fA-F]{12}$
Example:95b1b467-bd69-4436-8181-96c16408c230
Type of the resource attributes being represented
Allowed values:simulationcalculationresultopen-positionimport-open-positionsresult-detailreport
Example:simulation
CalculationType
objectData structure for all operations.
Basic attributes of the object.
Show Child Parameters
UUID type implementing the RFC 4122.
Match pattern:^[0-9a-fA-F]{8}\b-[0-9a-fA-F]{4}\b-[0-9a-fA-F]{4}\b-[0-9a-fA-F]{4}\b-[0-9a-fA-F]{12}$
Example:95b1b467-bd69-4436-8181-96c16408c230
Type of the resource attributes being represented
Allowed values:simulationcalculationresultopen-positionimport-open-positionsresult-detailreport
Example:simulation